> 热点资讯

新品日历

更多频道

修复旧CPU问题 赛博朋克2077 1.3版更新

CD PROJEKT RED此前发布了《赛博朋克 2077》的 1.3 更新,但是这个补丁阻止了游戏在不支持 AVX 指令集的 CPU 上运行。 幸运的是,来自国外的一位大神Jens Andree 发布了一个Mod,可以让玩家继续使用旧CPU 运行《赛博朋克2077》。

Jens Andree 说使用这个方案有点无奈,因为他无法在内存中找到关键点来防止这些调用,他只能简单地搜索每条指令并用 nop 修补它们。 因为它保留了所有的寄存器值,所以被修补的指令不会影响代码执行。

当玩家尝试使用不支持 AVX 指令集的 CPU 运行《赛博朋克 2077》1.3 版时,会弹出“EXCEPTION_ILLEGAL_INSTRUCTION (0xC000001D) crash”框。 Jens Andree 指出这是因为 AudioKinetic 声音引擎崩溃了。 于是他费心更新了33条AVX指令,让游戏再次正常运行,对于使用旧CPU玩这款游戏的玩家来说这个MOD还是非常有必要的。

打开ZOL新闻,阅读体验更佳

产品推荐

热门评论

更多评论

相关阅读

点击加载更多
全站导航
0

发评论,赚金豆

0 纠错